PHP errors when using the search function

Feedback, comments, and suggestions for the website
Post Reply
SentientTootsieRoll
Posts: 356
Joined: Tue Aug 02, 2016 2:26 pm
Location: Spokane, WA, US

PHP errors when using the search function

Post by SentientTootsieRoll » Sat Sep 01, 2018 9:54 pm

I've noticed that this site will throw back PHP errors when I search something occasionally. I attached an example. Here, I searched "backpackers" and while the first page worked, the second page is what gave me the error.

Here's the URL: search.php?st=0&sk=t&sd=d&sr=posts&keyw ... s&start=10

And a screenshot of what I'm receiving:
php-error.PNG
If we don't study the mistakes of the future, we're bound to repeat them for the first time.

User avatar
kman
Site Admin
Posts: 4288
Joined: Thu Jan 13, 2005 8:07 pm
Location: Charlotte, NC
Contact:

Re: PHP errors when using the search function

Post by kman » Sat Sep 01, 2018 10:07 pm

Thanks for reporting that. I think I know what the issue is so I'll get to work on tracking it down.

For those who are curious, here's what's happening...

We have a plug-in to phpBB that enables YouTube videos to be embedded and played right inside a post. Unfortunately, whenever we upgrade the forums software, which last happened maybe 6 months ago, something with the way that plug-in works breaks the embedded videos. The only way we've found to fix it is to run a script on the database that corrects the YouTube URLs. Unfortunately, that script only seems to catch about 95% of the YouTube URLs and the ones we miss cause those search/PHP errors.

I'll try to track down the offending post and get that URL fixed. If you run across any other search terms that cause errors, feel free to report them here or PM me and I'll track them down.

Post Reply